Should array variable names be plural

Question from Abdul#4709

Just wondering for arrays is it considered a better practice to keep the var names plural?

Or I guess it depends on language?

For me, when I name a collection of things it usually ends up that using plural describes it better, but it all depends on what you are naming.

I wouldn't make a collection of cats and call it cat. That's just confusing. But if you are keeping some messages in a queue messageQueue works as a name since having the word queue implies both the direction data flows and the idea of possible plurality.

<- Index